A note on Topic Prefix and Version Numbering

My little contributions to the phpBB 3.2.x and 3.3.x world. Please read the note on Version Numbering to ensure you download the correct Extension version.
Administrator
Site Admin
Posts: 756
Joined: Tue Nov 18, 2014 11:30 am

A note on Topic Prefix and Version Numbering

Post by Administrator »

Prefixes

[3.2][3.3][DEV] Extension in development for phpBB 3.2.x and 3.3.x
[3.2][3.3][RC] Release Candidate Extension for phpBB 3.2.x and 3.3.x
[3.2][3.3][CDB] Extension has been released on phpBB.com
[3.2][3.3][LATEST VERSION] An Updated Version of an Extension that has already been released on phpBB.com

Version Numbering

Because of some style differences between phpBB 3.1.x and 3.2.x/3.3.x I have had to adjust some of my Extensions. The version numbering has also changed where needed.

An Extension with a version number 3.1.x is for phpBB 3.1.x ONLY and has been moved to the phpBB 3.1.x/3.2.x/3.3.x Extensions

An Extension with a version number 3.2.x is for phpBB 3.2.x and 3.3.x

My other Extensions with a version number 1.x.x should work with either phpBB version without any adjustments. If you find any errors, please let me know.

Of course this only applies to my Extensions. Extensions built by other authors will have a different version numbering.
Administrator
Site Admin
Posts: 756
Joined: Tue Nov 18, 2014 11:30 am

Re: A note on Topic Prefix and Version Numbering

Post by Administrator »

As phpBB 3.1.x is now at its end of life I will no longer be developing 3.1.x extensions.

I will of course be keeping my 3.1.x extensions on this site for you to download, and will support where I can; but with php7 being universally available I suggest you move to phpBB 3.2.x with its associated extensions as soon as you can.
Administrator
Site Admin
Posts: 756
Joined: Tue Nov 18, 2014 11:30 am

Re: A note on Topic Prefix and Version Numbering

Post by Administrator »

I am gradually moving through my extensions to ensure that they are compatible with phpBB 3.3.x. Eventually all of my extensions for 3.2.x WILL be compatible with 3.3.x which will be noted by 3.3 in the topic title and the following icons in the first post

Image Image

All of my extensions that will work with 3.1.x ONLY will be moved to the Archive and will no longer be supported.

See the first post in this topic for more details