Header Banner module fails to launch

Please post any support questions here. Guest posting is allowed
John Robi
Posts: 16
Joined: Thu Mar 14, 2024 8:36 am

Header Banner module fails to launch

Post by John Robi »

Hello,

I have phpbb3 3.2.5 using php 5.4.45. I will be upgrading the phpbb3 next week.

My issue is the module Header Banner fails to launch; it gives this error message:

General Error
Module not accessible

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/functions_module.php
LINE: 565
CALL: trigger_error()

FILE: [ROOT]/adm/index.php
LINE: 82
CALL: p_master->load_active()

I did upload the folder headerbanner with all sub folders from a backup to the server (after renaming the existing folder).
But the same error displays.

Also, the files named in the error message do exist in their respective folders.

Any help is appreciated.
Administrator
Site Admin
Posts: 756
Joined: Tue Nov 18, 2014 11:30 am

Re: Header Banner module fails to launch

Post by Administrator »

Its probably a case of a corrupted file.

Disable and delete the extensions data from the ACP then delete the Header banner files from your server.

Download a fresh copy of the extension, unzip it on your computer and FTP it to your server and enable.
John Robi
Posts: 16
Joined: Thu Mar 14, 2024 8:36 am

Re: Header Banner module fails to launch

Post by John Robi »

Hello,

First things first, thank you for responding it is very much appreciated.

This is new to me. Your instructions are to disable Extensions in the ACP. Also to delete the Extensions.

I find in the ACP under Module Management the category, Extensions, and see that one may flag the category for disable and or delete. Again, I'm new at this, doesn't Extensions also include Board Announcements, Board Rules etc. If I first disable Extensions then, delete it will that not delete all extensions? I have never disabled or deleted anything in the ACP. I stepped in long after phpBB3 was installed. Just want to be really clear so I don't wipe out the board. After deleting Extensions in ACP then, I delete the Headerbanner folder and files from the server.

To continue, the instruction is after the upload of Headerbanner folder then, enable it. Question, once Extensions has been disabled and deleted in ACP does the Category listing of Extension remain so one can just enable it? Also, since Extensions looks to include Board Announcements, Board Rules etc. Do those modules need to configured again through the ACP in order for them to work?

As a note, currently, when I click on Extensions in the ACP it then displays a list of modules: Board Announcements, Board Rules etc. but there is no listing for Header Banner. Is this normal? When part of your instruction reads ...to your server and enable. Does enable mean just enable the category Extensions or is there something else to enable as well?

So sorry for being a novice at this.
Administrator
Site Admin
Posts: 756
Joined: Tue Nov 18, 2014 11:30 am

Re: Header Banner module fails to launch

Post by Administrator »

I'll attach some screenshots to make things clearer. Please follow the steps in the order listed.

Go to ACP> Customise and you will see the following (you will also have other entries for any extensions you have)

customise.jpg

Click Disable and confirm. Return to the same tab and Header Banner looking like this

disabled.jpg

Click delete data, confirm and you will see Enable next to the Header Banner entry. At this stage you can delete the files from your server using your FTP program. Going back to the Customise tab and the Header Banner entry will have gone.

Now download a new zip of the Header banner files and unzip them on your computer, then upload them to the ext directory using your FTP program.

Header Banner will nopw show in the customise tab, click enable and it will install the extension.


Go to General > Header Banner and you will see the configuration page as shown below

configutration.jpg

I hope that helps and this time the extension installs without error.
You do not have the required permissions to view the files attached to this post.
John Robi
Posts: 16
Joined: Thu Mar 14, 2024 8:36 am

Re: Header Banner module fails to launch

Post by John Robi »

Thank you so much.

Between the time I posted my last message and now, I figured out I was up the wrong tree and so I started back at square one and figured out everything you wrote in your last post and executed it. Synopsis, disabled/deleted data, deleted Headbanner folder from server. Uploaded replacement folder, enabled Header Banner, Launched Header Banner and... failure. Exact same error message. I did verify that in Customize/ Manage extensions under Header Banner it does show the revision level is 3.2.4. So it does see the newer files in the folder.

At a loss at this end. What do you recommend?
Administrator
Site Admin
Posts: 756
Joined: Tue Nov 18, 2014 11:30 am

Re: Header Banner module fails to launch

Post by Administrator »

Just to confirm, you did unzip on your computer before uploading the files, and NOT unzip on the server?

What FTP program are you using?
John Robi
Posts: 16
Joined: Thu Mar 14, 2024 8:36 am

Re: Header Banner module fails to launch

Post by John Robi »

Hello, an update, since deleting the data the banner no longer displays on any device. On inspection of the index file as viewed using View Page Source while on the phpBB3 it no longer displays any coding to find the website, no http:// to be found.

So, there must be some corrupted file some where. Your thoughts on what to do next?
Administrator
Site Admin
Posts: 756
Joined: Tue Nov 18, 2014 11:30 am

Re: Header Banner module fails to launch

Post by Administrator »

You need to replace the banners url (and indeed all the settings) in the configuration panel after deleting data.

Can I have a link to your site? (by PM if you prefer)
John Robi
Posts: 16
Joined: Thu Mar 14, 2024 8:36 am

Re: Header Banner module fails to launch

Post by John Robi »

Hello,

You write, "replace the banners url (and indeed all the settings) in the configuration panel after deleting data." With respect, please explain how I do that. The Header Banner module when clicked on results in this error:

General Error
Module not accessible

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/functions_module.php
LINE: 565
CALL: trigger_error()

FILE: [ROOT]/adm/index.php
LINE: 82
CALL: p_master->load_active()

The configuration screen never shows. This error is what I encountered which began this journey.

To send you a P.M. what name do I use in the address? After this post I'll look at the P.M. screen for "Administration" I guess.
John Robi
Posts: 16
Joined: Thu Mar 14, 2024 8:36 am

Re: Header Banner module fails to launch

Post by John Robi »

Hello,

I unzipped on my computer and I am using Filezilla. Also, I have set Filezilla settings file type default transfer type by un checking the box Treat files without extension as ASCII files. I believe this is required for phpBB software.