Hide Newest User Settings Options

Please post any support questions here. Guest posting is allowed
Pfizz
Posts: 5
Joined: Mon Aug 16, 2021 6:56 am

Hide Newest User Settings Options

Post by Pfizz »

Hi - I was wondering if there would be any way to expand the Whos Online settings to be able to choose the actual groups which which can see Whos Online and/or to block specific groups? As it is now the options are very limited. Thank you.
Administrator
Site Admin
Posts: 560
Joined: Tue Nov 18, 2014 11:30 am

Re: Hide Newest User Settings Options

Post by Administrator »

Not without a total rewrite of the extension, so I am afraid that this is not going to happen any time soon (if at all)
Pfizz
Posts: 5
Joined: Mon Aug 16, 2021 6:56 am

Re: Hide Newest User Settings Options

Post by Pfizz »

No worries. Thanks.
Pfizz
Posts: 5
Joined: Mon Aug 16, 2021 6:56 am

Re: Hide Newest User Settings Options

Post by Pfizz »

I discovered a small bug in the current version. I posted it here: https://www.phpbb.com/customise/db/exte ... pic/232406

Thanks.
Administrator
Site Admin
Posts: 560
Joined: Tue Nov 18, 2014 11:30 am

Re: Hide Newest User Settings Options

Post by Administrator »

I'm afraid I am in hospital with a broken hip right now. , and all the code is at home. I will look at it once I have recovered and back home.
Pfizz
Posts: 5
Joined: Mon Aug 16, 2021 6:56 am

Re: Hide Newest User Settings Options

Post by Pfizz »

So sorry to hear about your hip. I hope it heals up very quickly. :smt051

Meanwhile, I think I might have fixed it by going back and copying and replacing code from version 1.1.0 and pasting it into version 1.1.1-RC2. Thus, in the index_body_stat_blocks_before.html file I replaced the existing code of:

Code: Select all

{% EVENT index_body_block_online_prepend %}
{{ TOTAL_USERS_ONLINE ~ lang('ONLINE_EXPLAIN') }}<br />{{ RECORD_USERS }}<br /> <br />{{ LOGGED_IN_USER_LIST }}
{% if LEGEND %}<br /><em>{{ lang('LEGEND') ~ lang('COLON') }} {{ LEGEND }}</em>{% endif %}
{% EVENT index_body_block_online_append %}
with:

Code: Select all

{% EVENT index_body_block_online_prepend %}
{{ TOTAL_USERS_ONLINE }} ({{ lang('ONLINE_EXPLAIN') }})<br />{{ RECORD_USERS }}<br /> <br />{{ LOGGED_IN_USER_LIST }}
{% if LEGEND %}<br /><em>{{ lang('LEGEND') }}{{ lang('COLON') }} {{ LEGEND }}</em>{% endif %}
{% EVENT index_body_block_online_append %}
I believe that this has fixed it. Truth though is that I have no idea what I am doing when it comes to code or which file of code I needed to edit. So I just took a guess. And this was my first guess, but seemed to be the right one. Sometimes you just get lucky it seems. :)

Get well soon. :smt023
Administrator
Site Admin
Posts: 560
Joined: Tue Nov 18, 2014 11:30 am

Re: Hide Newest User Settings Options

Post by Administrator »

Hi my rule of thumb is if it works then its probably correct :mrg: I'll check properly when I can.

Thanks for the wishes, I'm awaiting the operation (hopefully) anytime soon
Pfizz
Posts: 5
Joined: Mon Aug 16, 2021 6:56 am

Re: Hide Newest User Settings Options

Post by Pfizz »

Thank you. I am seeing this right now on our site: In total there are 45 users online :: 4 registered, 1 hidden and 40 guests (based on users active over the past 5 minutes) so all looks good and it appears to match the original phpbb stock text. The code I changed it to was also just a copy and paste from your own older code as I mentioned, so I think its all good.

I hope you are not in a lot of pain and/or at least they got you on some useful meds to help make you more comfortable. At the moment I am dealing with some plantar fasciitis that just came on. Apparently the pain can last for months and I am not even sure how it happened. Hope it gets better sooner than later. Pain like this is no fun.

Anyway, after I made the fix to our site I suddenly started having a remote avatar problem. I am almost 100% certain, or I should say I am 100% certain that this edit to the extension code didn't cause it, but the timing was serendipitous so I ended up reversing the changes I made to the extension and the remote avatar problem still exists so that's how I know its a separate issue. I have found a way to partially fix the avatar problem, but would still like to try and figure out what is causing it in the first place so I can sort it out. I also posted something about it here:

https://www.phpbb.com/community/viewtop ... #p15753141

Best wishes...