Obscure Registration Code - Link in footer not displayed

Please post any support questions here. Guest posting is allowed
HaioPaio
Posts: 12
Joined: Sat Oct 03, 2020 12:37 pm

Obscure Registration Code - Link in footer not displayed

Post by HaioPaio »

Dear all
I have installed and activated Obscure Registration Code 1.0.0 RC11 under phpbb 3.3.3 and php 7.4 in two forums. There was no older version of the ext. installed before.
One forum is the live forum, the other one ist just a test forum under a subdomain.
On the live forum, I cannot see the link at the footer for displaying the registration code. No error is displayed. Just the link is not there.
On the testforum, everything works as expected.

Both forums work at the same configuration. I have disabled all extensions, except for Obscure Registration Code 1.0.0 RC11.
The style is prosilver, language British English. The live forum is https while the testforum is only http. Thats the only difference afaik.

What could I test next?
Administrator
Site Admin
Posts: 560
Joined: Tue Nov 18, 2014 11:30 am

Re: Obscure Registration Code - Link in footer not displayed

Post by Administrator »

Could you let me have a link to the live board.
HaioPaio
Posts: 12
Joined: Sat Oct 03, 2020 12:37 pm

Re: Obscure Registration Code - Link in footer not displayed

Post by HaioPaio »

Sure. It is der-räuchertreff.de
In the meantime alle extensions have been enabled, language German and style Orange BBEs is activated again.
Administrator
Site Admin
Posts: 560
Joined: Tue Nov 18, 2014 11:30 am

Re: Obscure Registration Code - Link in footer not displayed

Post by Administrator »

It looks like you might have an issue with overall_footer.html as its perfect in my test

screenshot_703.jpg

Replace the one in your boards prosilver from a fresh download, purge the cache and recheck
You do not have the required permissions to view the files attached to this post.
HaioPaio
Posts: 12
Joined: Sat Oct 03, 2020 12:37 pm

Re: Obscure Registration Code - Link in footer not displayed

Post by HaioPaio »

I've replaced overall footer and cleared cache in ACP and browser.
Unfortunately, no success.
Did you run your test on my site? Your screenshot looks different than my registration page.
If you wish, i would provide you log in credentials at any desired level. Let me know.
My test forum can be found at ft2.der-räuchertreff.de. I noticed that the square with the key icon is empty at my test forum.
Bildschirmfoto 2021-08-12 um 10.20.09.jpg
You do not have the required permissions to view the files attached to this post.
Administrator
Site Admin
Posts: 560
Joined: Tue Nov 18, 2014 11:30 am

Re: Obscure Registration Code - Link in footer not displayed

Post by Administrator »

I have done some more checking on your site and it might be that the extension has not fully uploaded correctly, also I have just released a new version at addresses an unrelated issue.

Disable it, download a set of fresh files from HERE unzip, upload and enable

If that doesn't work, the cPanel access will allow me to check further.
HaioPaio
Posts: 12
Joined: Sat Oct 03, 2020 12:37 pm

Re: Obscure Registration Code - Link in footer not displayed

Post by HaioPaio »

Thanks for the new version. Unfortunately, it did not fix the problem.
Both forums are hosted by Strato. They do not use cpanel. Do you need access to the database or would you need ftp access to the files. This would be two different credentials. I can certainly give you both. Just let me know.
The error log does not show any php errors.
Administrator
Site Admin
Posts: 560
Joined: Tue Nov 18, 2014 11:30 am

Re: Obscure Registration Code - Link in footer not displayed

Post by Administrator »

Better have both access just to check everything. PM or Email whichever you feel most comfortable with
HaioPaio
Posts: 12
Joined: Sat Oct 03, 2020 12:37 pm

Re: Obscure Registration Code - Link in footer not displayed

Post by HaioPaio »

OK, I'll create accounts for you and send it via PM.

New information:
After upgrading the test forum to RC12, the link disappears from the footer. After downgrading to RC11, the link is visible again and the extension works. Unfortunately only in the test forum and not in the live forum.
At the live forum, both RC11 and RC12 do not display the footer link.

I noticed that the Key symbol ( FA icon ? ) inside the little square, left of the code is not displayed. The square is empty, no matter if using preview in ACP or after clicking at the footer link.
HaioPaio
Posts: 12
Joined: Sat Oct 03, 2020 12:37 pm

Re: Obscure Registration Code - Link in footer not displayed

Post by HaioPaio »

PM has been sent to you.