Header Links error

Please post any support questions here. Guest posting is allowed
Verks

Header Links error

Post by Verks »

So I recently downloaded HiFiKabin's 3.2.1-RC3 Header Link extension, and whenever I enable the header link through the ACP, my website shows an "HTTP ERROR 500". However, when I disable the Header Link, my website works again, someone help me with this.
Administrator
Site Admin
Posts: 560
Joined: Tue Nov 18, 2014 11:30 am

Re: Header Links error

Post by Administrator »

I have never come across a 500 error when installing this extension before. All very strange. A 500 error is a server error and is shown when the server can not carry out the request.

My first suggestion is to contact your hosting company and tell them the problem asking if they can send you the server logs for the time the error happens. That may give a clue.

Also:-
Can you install other extensions?
Try installing an earlier version of this extension and see if that works OK
How did you upload this extension?

That and any other information you can give may help get to the bottom of the problem.
Verks

Re: Header Links error

Post by Verks »

Administrator wrote: Sat Feb 20, 2021 9:57 am I have never come across a 500 error when installing this extension before. All very strange. A 500 error is a server error and is shown when the server can not carry out the request.

My first suggestion is to contact your hosting company and tell them the problem asking if they can send you the server logs for the time the error happens. That may give a clue.

Also:-
Can you install other extensions?
Try installing an earlier version of this extension and see if that works OK
How did you upload this extension?

That and any other information you can give may help get to the bottom of the problem.
I tried RC1 of the latest version, still gives me the error, I followed your steps that you provided when you released this extension, I re-installed the extension twice, still doesn't work, however I'll try to download an earlier version of the extension to see if this works.
Administrator
Site Admin
Posts: 560
Joined: Tue Nov 18, 2014 11:30 am

Re: Header Links error

Post by Administrator »

I'll wait to hear back from you
Verks

Re: Header Links error

Post by Verks »

So I tried 3 other versions, and it still gives me the error.. Could it be something in my overall_header document? Or something in any of the .css documents at all? I'm lost at this point..
Verks

Re: Header Links error

Post by Verks »

Could it be that it's only compatible with the default phpbb style?
Administrator
Site Admin
Posts: 560
Joined: Tue Nov 18, 2014 11:30 am

Re: Header Links error

Post by Administrator »

What style are you using?
Verks

Re: Header Links error

Post by Verks »

I'm using CleanSilver.
Administrator
Site Admin
Posts: 560
Joined: Tue Nov 18, 2014 11:30 am

Re: Header Links error

Post by Administrator »

The extension will need adapting to work with CleanSilver, BUT that is not the cause of the error. I can install it without any errors at all, it just fails to show the banner.

Can you install ANY extensions?
Have you checked/asked your host for the server logs?
Verks

Re: Header Links error

Post by Verks »

I haven't tried any other extensions, however here are the logs:


Code: Select all

Fatal error: Uncaught Twig\Error\LoaderError: Unable to find template "@hifikabin_headerlink/headerlink.css" (looked into: /home/vol6_6/epizy.com/epiz_27932281/htdocs/ext/hifikabin/headerlink/styles/prosilver/template) in "@hifikabin_headerlink/event/overall_header_head_append.html" at line 2. in /home/vol6_6/epizy.com/epiz_27932281/htdocs/vendor/twig/twig/src/Loader/FilesystemLoader.php:250 Stack trace: #0 /home/vol6_6/epizy.com/epiz_27932281/htdocs/phpbb/template/twig/loader.php(135): Twig\Loader\FilesystemLoader->findTemplate('@hifikabin_head...', true) #1 /home/vol6_6/epizy.com/epiz_27932281/htdocs/vendor/twig/twig/src/Loader/FilesystemLoader.php(150): phpbb\template\twig\loader->findTemplate('@hifikabin_head...') #2 /home/vol6_6/epizy.com/epiz_27932281/htdocs/phpbb/template/twig/environment.php(328): Twig\Loader\FilesystemLoader->getCacheKey('@hifikabin_head...') #3 /home/vol6_6/epizy.com/epiz_27932281/htdocs/cache/production/twig/08/08496c2ab96189cc33ca61413dab47dba4cf6e2215c0b036b6485bc9eb0f63c5.php(45): phpbb\temp in /home/vol6_6/epizy.com/epiz_27932281/htdocs/vendor/twig/twig/src/Loader/FilesystemLoader.php on line 250